Not able to server .well-known folder

I need to serve a file inside a .well-know/pki-validator/ folder. No matter what I do I’m not able to serve anything inside these folders. I already tried with other folder names and worked fine but this specific name does not to work.
Any idea on why this could happen or how fix it?

Hi and welcome to Honeyside!

Hidden files (starting with dot) are hidden by default.

Try changing line 568 in index,js:



server.use(serve(getPath(match.location), {hidden: true}));

Could you give me the full path to the file you are referring to? I’m not able to find it

Hi! The file is index.js inside Acacia’s main folder or repo.

Here is the Github URL: Acacia/index.js at master · Honeyside/Acacia · GitHub

Tried that option but keeps seeing the same Not Found error messages when accessing the file on browser.
I created another hidden folder .sample/ and I’m able to access file inside of it but anything inside .well-known is not accessible.

Checking the Acacia’s logs I see a message saying Serving available ACME challenges..

I don’t know if Acacia is preventing the access the the .well-known folder and using it in another way


Sorry, my bad. Upon closer look, you need to put the files under ACACIA_FOLDER/acme/webroot

This folder is already configured with hidden: true, which means you don’t need the change from before.

Have a sweet day!

I putted the file there however I still cannot access the file
Do I just put the file in that folder and will be accessible throught the .well-known path on the browser?
Do I only need to paste the file and restart the server?

For anyone having this issue you need to put the files under ACACIA_FOLDER/acme/webroot/.well-known/pki-validation/